Google releases July 2017 Android Security Bulletin and Google Device Images

0 67,935

Google has released the July 2017 Android Security Bulletin. Partners have had access to the warnings in this month’s bulletin at least a month ago.

The July bulletin has two security patch levels to provide Android partners with the flexibility to more quickly fix a subset of vulnerabilities that are similar across all Android devices.

  • 2017-07-01: Partial security patch level string. This security patch level string indicates that all issues associated with 2017-07-01 (and all previous security patch level strings) are addressed.
  • 2017-07-05: Complete security patch level string. This security patch level string indicates that all issues associated with 2017-07-01 and 2017-07-05 (and all previous security patch level strings) are addressed.

The most severe of these issues is a critical security vulnerability in media framework that could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process. The severity assessment is based on the effect that exploiting the vulnerability would possibly have on an affected device, assuming the platform and service mitigations are turned off for development purposes or if successfully bypassed.

Google releases July 2017 Android Security Bulletin and Google Device Images

Alongside the bulletin, Google have released a security update to Google devices through an over-the-air (OTA) update. The Google device firmware images have also been released to the Google Developer site. Security patch levels of July 05, 2017 or later address all of these issues.

The tables below contains a list of security vulnerabilities, the Common Vulnerability and Exposures ID (CVE), the assessed severity, and whether or not Google devices are affected. The severity assessment is based on the effect that exploiting the vulnerability would possibly have on an affected device, assuming the platform and service mitigations are disabled for development purposes or if successfully bypassed.

Android and Google Play Mitigations

This is a summary of the mitigations provided by the Android security platform and service protections such as Google Play Protect. These capabilities reduce the likelihood that security vulnerabilities could be successfully exploited on Android.

  • Exploitation for many issues on Android is made more difficult by enhancements in newer versions of the Android platform. We encourage all users to update to the latest version of Android where possible.
  • The Android security team actively monitors for abuse through Google Play Protect and warns users about Potentially Harmful Applications. Google Play Protect is enabled by default on devices with Google Mobile Services, and is especially important for users who install apps from outside of Google Play.

Security patch levels of 2017-07-01 or later must address the following issues.

Runtime

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of an unprivileged process.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-3544A-35784677RCEModerate4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Framework

The most severe vulnerability in this section could enable a local malicious application using a specially crafted file to execute arbitrary code within the context of an application that uses the library.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-0664A-36491278EoPHigh5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0665A-36991414EoPHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0666A-37285689EoPHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0667A-37478824EoPHigh5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0668A-22011579IDModerate4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0669A-34114752IDHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0670A-36104177DoSHigh5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Libraries

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of an application that uses the library.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-0671A-34514762RCEHigh4.4.4
CVE-2016-2109A-35443725DoSHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0672A-34778578DoSHigh7.0, 7.1.1, 7.1.2

Media framework

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-0540A-33966031RCECritical5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0673A-33974623RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0674A-34231163RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0675A-34779227RCECritical6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0676A-34896431RCECritical5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0677A-36035074RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0678A-36576151RCECritical7.0, 7.1.1, 7.1.2
CVE-2017-0679A-36996978RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0680A-37008096RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0681A-37208566RCECritical4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0682A-36588422RCEHigh7.0, 7.1.1, 7.1.2
CVE-2017-0683A-36591008RCEHigh7.0, 7.1.1, 7.1.2
CVE-2017-0684A-35421151EoPHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0685A-34203195DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0686A-34231231DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0688A-35584425DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0689A-36215950DoSHigh5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0690A-36592202DoSHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0691A-36724453DoSHigh7.0, 7.1.1, 7.1.2
CVE-2017-0692A-36725407DoSHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0693A-36993291DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0694A-37093318DoSHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0695A-37094889DoSHigh5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0696A-37207120DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0697A-37239013DoSHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0698A-35467458IDModerate6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0699A-36490809IDModerate6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

System UI

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-0700A-35639138RCEHigh7.1.1, 7.1.2
CVE-2017-0701A-36385715RCEHigh7.1.1, 7.1.2
CVE-2017-0702A-36621442RCEHigh7.1.1, 7.1.2
CVE-2017-0703A-33123882EoPHigh4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0704A-33059280EoPModerate7.1.1, 7.1.2

Security patch levels of 2017-07-05 or later must address all of the 2017-07-01 issues, as well as the following issues.

Broadcom components

The most severe vulnerability in this section could enable a proximate attacker to execute arbitrary code within the context of the kernel.

CVEReferencesTypeSeverityComponent
CVE-2017-9417A-38041027*
B-RB#123023
RCECriticalWi-Fi driver
CVE-2017-0705A-34973477*
B-RB#119898
EoPModerateWi-Fi driver
CVE-2017-0706A-35195787*
B-RB#120532
EoPModerateWi-Fi driver

HTC components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-0707A-36088467*EoPModerateLED driver
CVE-2017-0708A-35384879*IDModerateSound driver
CVE-2017-0709A-35468048*IDLowSensor hub driver

Kernel components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-6074A-35784697
Upstream kernel
EoPHighNetworking subsystem
CVE-2017-5970A-35805460
Upstream kernel
DoSHighNetworking subsystem
CVE-2015-5707A-35841297
Upstream kernel
EoPModerateSCSI driver
CVE-2017-0710A-34951864*EoPModerateTCB
CVE-2017-7308A-36725304
Upstream kernel
EoPModerateNetworking driver
CVE-2014-9731A-35841292
Upstream kernel
IDModerateFile system

MediaTek components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-0711A-36099953*
M-ALPS03206781
EoPHighNetworking driver

NVIDIA components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-0340A-33968204*
N-CVE-2017-0340
EoPHighLibnvparser
CVE-2017-0326A-33718700*
N-CVE-2017-0326
IDModerateVideo driver

Qualcomm components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of the kernel.

CVEReferencesTypeSeverityComponent
CVE-2017-8255A-36251983
QC-CR#985205
EoPHighBootloader
CVE-2016-10389A-34500449
QC-CR#1009145
EoPHighBootloader
CVE-2017-8253A-35400552
QC-CR#1086764
EoPHighCamera driver
CVE-2017-8262A-32938443
QC-CR#2029113
EoPHighGPU driver
CVE-2017-8263A-34126808*
QC-CR#1107034
EoPHighAnonymous shared memory subsystem
CVE-2017-8267A-34173755*
QC-CR#2001129
EoPHighAnonymous shared memory subsystem
CVE-2017-8273A-35400056
QC-CR#1094372
EoPHighBootloader
CVE-2016-5863A-36251182
QC-CR#1102936
EoPModerateUSB HID driver
CVE-2017-8243A-34112490*
QC-CR#2001803
EoPModerateSoC driver
CVE-2017-8246A-37275839
QC-CR#2008031
EoPModerateSound driver
CVE-2017-8256A-37286701
QC-CR#1104565
EoPModerateWi-Fi driver
CVE-2017-8257A-37282763
QC-CR#2003129
EoPModerateVideo driver
CVE-2017-8259A-34359487
QC-CR#2009016
EoPModerateSoC driver
CVE-2017-8260A-34624155
QC-CR#2008469
EoPModerateCamera driver
CVE-2017-8261A-35139833
QC-CR#2013631
EoPModerateCamera driver
CVE-2017-8264A-33299365
QC-CR#1107702
EoPModerateCamera driver
CVE-2017-8265A-32341313
QC-CR#1109755
EoPModerateVideo driver
CVE-2017-8266A-33863407
QC-CR#1110924
EoPModerateVideo driver
CVE-2017-8268A-34620535
QC-CR#2002207
EoPModerateCamera driver
CVE-2017-8270A-35468665
QC-CR#2021363
EoPModerateWi-Fi driver
CVE-2017-8271A-35950388
QC-CR#2028681
EoPModerateVideo driver
CVE-2017-8272A-35950805
QC-CR#2028702
EoPModerateVideo driver
CVE-2017-8254A-36252027
QC-CR#832914
IDModerateSound driver
CVE-2017-8258A-37279737
QC-CR#2005647
IDModerateCamera driver
CVE-2017-8269A-33967002
QC-CR#2013145
IDModerateIPA Driver

Qualcomm closed-source components

These vulnerabilities affect Qualcomm components and are described in further detail in Qualcomm AMSS security bulletins in 2014-2016. They are included in this Android security bulletin in order to associate their fixes with an Android security patch level. Fixes for these vulnerabilities are available directly from Qualcomm.

CVEReferencesTypeSeverityComponent
CVE-2014-9411A-37473054
QC-CR#532956
N/AHighSecure systems group
CVE-2014-9968A-37304413
QC-CR#642084
N/AHighModem
CVE-2014-9973A-37470982
QC-CR#646919
N/AHighSecure systems group
CVE-2014-9974A-37471979
QC-CR#654072
N/AHighSecure systems group
CVE-2014-9975A-37471230
QC-CR#700125
N/AHighSecure systems group
CVE-2014-9977A-37471087
QC-CR#703002
N/AHighSecure systems group
CVE-2014-9978A-37468982
QC-CR#709939
N/AHighSecure systems group
CVE-2014-9979A-37471088
QC-CR#717304
N/AHighSecure systems group
CVE-2014-9980A-37471029
QC-CR#709766
N/AHighSecure systems group
CVE-2015-0575A-37296999
QC-CR#715815
N/AHighModem
CVE-2015-8592A-37470090
QC-CR#775396
N/AHighCore
CVE-2015-8595A-37472411
QC-CR#790151
N/AHighSecure systems group
CVE-2015-8596A-37472806
QC-CR#802005
N/AHighSecure systems group
CVE-2015-9034A-37305706
QC-CR#614512
N/AHighModem
CVE-2015-9035A-37303626
QC-CR#750231
N/AHighModem
CVE-2015-9036A-37303519
QC-CR#751831
N/AHighModem
CVE-2015-9037A-37304366
QC-CR#753315
N/AHighModem
CVE-2015-9038A-37303027
QC-CR#758328
N/AHighModem
CVE-2015-9039A-37302628
QC-CR#760282
N/AHighModem
CVE-2015-9040A-37303625
QC-CR#761216
N/AHighModem
CVE-2015-9041A-37303518
QC-CR#762126
N/AHighModem
CVE-2015-9042A-37301248
QC-CR#762214
N/AHighModem
CVE-2015-9043A-37305954
QC-CR#762954
N/AHighModem
CVE-2015-9044A-37303520
QC-CR#764858
N/AHighModem
CVE-2015-9045A-37302136
QC-CR#766189
N/AHighModem
CVE-2015-9046A-37301486
QC-CR#767335
N/AHighModem
CVE-2015-9047A-37304367
QC-CR#779285
N/AHighModem
CVE-2015-9048A-37305707
QC-CR#795960
N/AHighModem
CVE-2015-9049A-37301488
QC-CR#421589, QC-CR#817165
N/AHighModem
CVE-2015-9050A-37302137
QC-CR#830102
N/AHighModem
CVE-2015-9051A-37300737
QC-CR#837317
N/AHighModem
CVE-2015-9052A-37304217
QC-CR#840483
N/AHighModem
CVE-2015-9053A-37301249
QC-CR#843808
N/AHighModem
CVE-2015-9054A-37303177
QC-CR#856077
N/AHighModem
CVE-2015-9055A-37472412
QC-CR#806464
N/AHighCore
CVE-2015-9060A-37472807
QC-CR#817343
N/AHighSecure systems group
CVE-2015-9061A-37470436
QC-CR#824195
N/AHighSecure systems group
CVE-2015-9062A-37472808
QC-CR#802039
N/AHighSecure systems group
CVE-2015-9067A-37474000
QC-CR#848926
N/AHighSecure systems group
CVE-2015-9068A-37470144
QC-CR#851114
N/AHighSecure systems group
CVE-2015-9069A-37470777
QC-CR#854496
N/AHighSecure systems group
CVE-2015-9070A-37474001
QC-CR#877102
N/AHighSecure systems group
CVE-2015-9071A-37471819
QC-CR#877276
N/AHighSecure systems group
CVE-2015-9072A-37474002
QC-CR#877361
N/AHighSecure systems group
CVE-2015-9073A-37473407
QC-CR#878073
N/AHighSecure systems group
CVE-2016-10343A-32580186
QC-CR#972213
N/AHighModem
CVE-2016-10344A-32583954
QC-CR#1022360
N/AHighModem
CVE-2016-10346A-37473408
QC-CR#896584
N/AHighCore
CVE-2016-10347A-37471089
QC-CR#899671
N/AHighCore
CVE-2016-10382A-28823584
QC-CR#944014
N/AHighSecure systems group
CVE-2016-10383A-28822389
QC-CR#960624
N/AHighSecure systems group
CVE-2016-10388A-32580294
QC-CR#992749
N/AHighSecure systems group
CVE-2016-10391A-32583804
QC-CR#970283
N/AHighWConnect
CVE-2016-5871A-37473055
QC-CR#883013
N/AHighSecure systems group
CVE-2016-5872A-37472809
QC-CR#886220
N/AHighSecure systems group

Google device updates

This table contains the security patch level in the latest over-the-air update (OTA) and firmware images for Google devices. The Google device firmware images are available on the Google Developer site.

Google deviceSecurity patch level
Pixel / Pixel XLJuly 05, 2017
Nexus 5XJuly 05, 2017
Nexus 6July 05, 2017
Nexus 6PJuly 05, 2017
Nexus 9July 05, 2017
Nexus PlayerJuly 05, 2017
Pixel CJuly 05, 2017

Full details of the July 2017 Android Security Bulletin is available here.

 

Essential SSL