google april 2018 android security bulletin

Google releases April 2018 Android Security Bulletin and Google Device Images

Last updated:

Google has released the April 2018 Android Security Bulletin. Partners have had access to the warnings in this month’s bulletin for at least a month.

The April bulletin has two security patch levels to provide Android partners with the flexibility to more quickly fix a subset of vulnerabilities that are similar across all Android devices.

  • 2018-04-01: Partial security patch level string. This security patch level string indicates that all issues associated with 2018-04-01 (and all previous security patch level strings) are addressed.
  • 2018-04-05: Complete security patch level string. This security patch level address all issues associated with the 2018-04-05 security patch level and all previous patch levels.

The most severe of these issues is a critical security vulnerability in Media framework that could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process. The severity assessment is based on the effect that exploiting the vulnerability would possibly have on an affected device, assuming the platform and service mitigations are turned off for development purposes or if successfully bypassed.

Alongside the bulletin, Google have released a security update to Google devices through an over-the-air (OTA) update. The Google device firmware images have also been released to the Google Developer site. Security patch levels of April 5, 2018 or later address all of these issues.

The tables below contains a list of security vulnerabilities, the Common Vulnerability and Exposures ID (CVE), the assessed severity, and whether or not Google devices are affected. The severity assessment is based on the effect that exploiting the vulnerability would possibly have on an affected device, assuming the platform and service mitigations are disabled for development purposes or if successfully bypassed.

Android and Google Service Mitigations

This is a summary of the mitigations provided by the Android security platform and service protections such as Google Play Protect. These capabilities reduce the likelihood that security vulnerabilities could be successfully exploited on Android.

  • Exploitation for many issues on Android is made more difficult by enhancements in newer versions of the Android platform. All users are encouraged to update to the latest version of Android where possible.
  • The Android security team actively monitors for abuse through Google Play Protect and warns users about Potentially Harmful Applications. Google Play Protect is enabled by default on devices with Google Mobile Services, and is especially important for users who install apps from outside of Google Play.

2018-04-01 security patch level—Vulnerability details

Android runtime

The most severe vulnerability in this section could enable a remote attacker to bypass user interaction requirements in order to gain access to additional permissions.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-13274A-71360761EoPHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Framework

The most severe vulnerability in this section could enable a local malicious application to bypass operating system protections that isolate application data from other applications.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-13275A-70808908IDHigh8.0, 8.1

Media framework

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-13276A-70637599RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13277A-72165027RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13278A-70546581EoPHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13279A-68399439DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13280A-71361451DoSHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

System

The most severe vulnerability in this section could enable a remote attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityUpdated AOSP versions
CVE-2017-13281A-71603262RCECritical8.0, 8.1
CVE-2017-13282A-71603315RCECritical7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13283A-71603410RCECritical7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13267A-69479009RCECritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13284A-70808273EoPCritical6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13285A-69177126RCEHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13286A-69683251EoPHigh8.0, 8.1
CVE-2017-13287A-71714464EoPHigh6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13288A-69634768EoPHigh8.0, 8.1
CVE-2017-13289A-70398564EoPHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13290A-69384124IDHigh6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2017-13291A-71603553DoSHigh7.0, 7.1.1, 7.1.2, 8.0, 8.1

2018-04-05 security patch level—Vulnerability details

Broadcom components

The most severe vulnerability in this section could enable a proximate attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-13292A-70722061
B-V2018010201
RCECriticalbcmdhd driver

Kernel components

The most severe vulnerability in this section could enable a local malicious application to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-13293A-62679701EoPHighNFC driver
CVE-2017-5754A-69856074IDHighMemory mapping
CVE-2017-1653A-69052594
Upstream kernel
IDHighUSB

Qualcomm components

The most severe vulnerability in this section could enable a proximate attacker using a specially crafted file to execute arbitrary code within the context of a privileged process.

CVEReferencesTypeSeverityComponent
CVE-2017-15822A-71501534
QC-CR#2123807
RCECriticalWiFi
CVE-2017-17770A-70237684
QC-CR#2103199
EoPHighBinder
CVE-2018-3566A-72957177
QC-CR#2143847
EoPHighWLAN
CVE-2018-3563A-72956842
QC-CR#2143207
EoPHighAudio Driver
CVE-2017-13077A-72957017
QC-CR#2129237
IDHighWLAN

Qualcomm closed-source components

These vulnerabilities affect Qualcomm components and are described in further detail in the appropriate Qualcomm AMSS security bulletin or security alert. The severity assessment of these issues is provided directly by Qualcomm.

CVEReferencesTypeSeverityComponent
CVE-2017-18071A-68326813N/ACriticalClosed-source component
CVE-2017-8274A-68141335N/ACriticalClosed-source component
CVE-2017-18146A-70221449N/ACriticalClosed-source component
CVE-2017-18128A-70221448N/ACriticalClosed-source component
CVE-2018-3592A-71501105N/ACriticalClosed-source component
CVE-2018-3591A-71501103N/ACriticalClosed-source component
CVE-2017-18074A-68326816N/AHighClosed-source component
CVE-2017-18073A-68326820N/AHighClosed-source component
CVE-2017-18125A-68326821N/AHighClosed-source component
CVE-2017-8275A-68141336N/AHighClosed-source component
CVE-2017-11011A-68326823N/AHighClosed-source component
CVE-2017-18137A-67712318N/AHighClosed-source component
CVE-2017-18134A-67712320N/AHighClosed-source component
CVE-2017-18136A-68989810N/AHighClosed-source component
CVE-2017-18140A-68989811N/AHighClosed-source component
CVE-2017-18135A-68989813N/AHighClosed-source component
CVE-2017-18142A-68989814N/AHighClosed-source component
CVE-2017-18138A-68989815N/AHighClosed-source component
CVE-2017-18139A-68989819N/AHighClosed-source component
CVE-2017-18129A-68989822N/AHighClosed-source component
CVE-2017-18132A-68989825N/AHighClosed-source component
CVE-2017-18133A-68989826N/AHighClosed-source component
CVE-2017-18072A-68989828N/AHighClosed-source component
CVE-2017-18126A-68989829N/AHighClosed-source component
CVE-2017-18144A-70221450N/AHighClosed-source component
CVE-2017-18145A-70221453N/AHighClosed-source component
CVE-2017-18147A-70221456N/AHighClosed-source component
CVE-2017-18130A-70221460N/AHighClosed-source component
CVE-2017-18143A-70221461N/AHighClosed-source component
CVE-2017-18127A-70221462N/AHighClosed-source component
CVE-2018-3590A-71501106N/AHighClosed-source component
CVE-2018-3593A-71501107N/AHighClosed-source component
CVE-2018-3589A-71501108N/AHighClosed-source component
CVE-2018-3594A-71501112N/AHighClosed-source component

Qualcomm closed-source components

2014-2016 cumulative update

These vulnerabilities affect Qualcomm components and were shared by Qualcomm with their partners through Qualcomm AMSS security bulletins or security alerts between 2014 and 2016. They are included in this Android security bulletin in order to associate them with a security patch level (many Android devices may have already addressed these issues in prior updates). The severity assessment of these issues is provided directly by Qualcomm.

CVEReferencesTypeSeverityComponent
CVE-2014-9996A-37535090N/ACriticalClosed-source component
CVE-2014-9971A-37546253N/AHighClosed-source component
CVE-2014-9972A-37546853N/AHighClosed-source component
CVE-2014-10063A-37534948N/AHighClosed-source component
CVE-2014-10057A-62261099N/AHighClosed-source component
CVE-2014-10059A-62260706N/AHighClosed-source component
CVE-2014-10053A-37544066N/AHighClosed-source component
CVE-2014-10054A-62261100N/AHighClosed-source component
CVE-2014-10052A-62258372N/AHighClosed-source component
CVE-2014-10050A-37546901N/AHighClosed-source component
CVE-2014-10055A-37545605N/AHighClosed-source component
CVE-2014-10051A-37546302N/AHighClosed-source component
CVE-2014-10048A-62258088N/AHighClosed-source component
CVE-2014-10062A-62258373N/AHighClosed-source component
CVE-2014-10058A-62260741N/AHighClosed-source component
CVE-2014-10047A-37538492N/AHighClosed-source component
CVE-2014-10045A-62258536N/AHighClosed-source component
CVE-2014-10056A-62261338N/AHighClosed-source component
CVE-2014-9976A-37534895N/AHighClosed-source component
CVE-2014-10043A-62259947N/AHighClosed-source component
CVE-2014-10044A-62260777N/AHighClosed-source component
CVE-2014-10046A-62261408N/AHighClosed-source component
CVE-2014-9981A-37534949N/AHighClosed-source component
CVE-2014-9993A-37540928N/AHighClosed-source component
CVE-2014-9986A-37534645N/AHighClosed-source component
CVE-2014-9994A-37538493N/AHighClosed-source component
CVE-2014-9995A-37546303N/AHighClosed-source component
CVE-2014-9997A-37546854N/AHighClosed-source component
CVE-2014-9988A-62258089N/AHighClosed-source component
CVE-2014-9990A-62261216N/AHighClosed-source component
CVE-2014-9987A-62261293N/AHighClosed-source component
CVE-2014-9989A-62261380N/AHighClosed-source component
CVE-2014-9991A-62261409N/AHighClosed-source component
CVE-2014-10039A-62261608N/AHighClosed-source component
CVE-2014-9985A-62261609N/AHighClosed-source component
CVE-2015-9204A-37540929N/AHighClosed-source component
CVE-2015-0574A-37546304N/AHighClosed-source component
CVE-2015-9205A-37534696N/AHighClosed-source component
CVE-2015-9221A-37534796N/AHighClosed-source component
CVE-2015-9212A-37535795N/AHighClosed-source component
CVE-2015-9210A-62258538N/AHighClosed-source component
CVE-2015-9211A-62261217N/AHighClosed-source component
CVE-2015-9207A-62261410N/AHighClosed-source component
CVE-2015-9202A-37540473N/AHighClosed-source component
CVE-2015-9213A-37547700N/AHighClosed-source component
CVE-2015-9209A-38193247N/AHighClosed-source component
CVE-2015-9203A-62261218N/AHighClosed-source component
CVE-2015-9206A-62261294N/AHighClosed-source component
CVE-2015-9215A-62251854N/AHighClosed-source component
CVE-2015-9216A-62260780N/AHighClosed-source component
CVE-2015-9169A-37535098N/AHighClosed-source component
CVE-2015-9173A-37536244N/AHighClosed-source component
CVE-2015-9179A-37542567N/AHighClosed-source component
CVE-2015-9177A-37544075N/AHighClosed-source component
CVE-2015-9187A-37544109N/AHighClosed-source component
CVE-2015-9162A-37544110N/AHighClosed-source component
CVE-2015-9172A-37545607N/AHighClosed-source component
CVE-2015-9181A-37546754N/AHighClosed-source component
CVE-2015-9219A-37546859N/AHighClosed-source component
CVE-2015-9183A-37546860N/AHighClosed-source component
CVE-2015-9182A-37546904N/AHighClosed-source component
CVE-2015-9185A-37546952N/AHighClosed-source component
CVE-2015-9184A-37546953N/AHighClosed-source component
CVE-2015-9170A-37546954N/AHighClosed-source component
CVE-2015-9175A-37547404N/AHighClosed-source component
CVE-2015-9171A-37547405N/AHighClosed-source component
CVE-2015-9192A-37547750N/AHighClosed-source component
CVE-2015-9208A-62258540N/AHighClosed-source component
CVE-2015-9224A-62259949N/AHighClosed-source component
CVE-2015-9201A-62260711N/AHighClosed-source component
CVE-2015-9200A-62260779N/AHighClosed-source component
CVE-2015-9198A-62261219N/AHighClosed-source component
CVE-2015-9196A-62261339N/AHighClosed-source component
CVE-2015-9199A-62261411N/AHighClosed-source component
CVE-2015-9174A-62258090N/AHighClosed-source component
CVE-2015-9178A-62258541N/AHighClosed-source component
CVE-2015-9180A-62260712N/AHighClosed-source component
CVE-2015-9176A-62260713N/AHighClosed-source component
CVE-2015-9189A-62260820N/AHighClosed-source component
CVE-2015-9188A-62260821N/AHighClosed-source component
CVE-2015-0576A-37543715N/AHighClosed-source component
CVE-2015-9156A-62260743N/AHighClosed-source component
CVE-2015-9195A-62251855N/AHighClosed-source component
CVE-2015-9197A-62260742N/AHighClosed-source component
CVE-2015-9218A-62260781N/AHighClosed-source component
CVE-2015-9217A-62261295N/AHighClosed-source component
CVE-2015-9166A-62251856N/AHighClosed-source component
CVE-2015-9164A-62258542N/AHighClosed-source component
CVE-2015-9190A-62259744N/AHighClosed-source component
CVE-2015-9159A-62259745N/AHighClosed-source component
CVE-2015-9167A-62259950N/AHighClosed-source component
CVE-2015-9191A-62260394N/AHighClosed-source component
CVE-2015-9161A-62260462N/AHighClosed-source component
CVE-2015-9163A-62260822N/AHighClosed-source component
CVE-2015-9158A-62261381N/AHighClosed-source component
CVE-2015-9152A-37546305N/AHighClosed-source component
CVE-2015-9144A-37540474N/AHighClosed-source component
CVE-2015-9165A-37539224N/AHighClosed-source component
CVE-2015-9223A-37543718N/AHighClosed-source component
CVE-2015-9222A-62258374N/AHighClosed-source component
CVE-2015-9193A-62259951N/AHighClosed-source component
CVE-2015-9194A-62261296N/AHighClosed-source component
CVE-2015-9153A-62260395N/AHighClosed-source component
CVE-2015-9151A-62260396N/AHighClosed-source component
CVE-2015-9148A-62260463N/AHighClosed-source component
CVE-2015-9149A-62260744N/AHighClosed-source component
CVE-2015-9146A-62260745N/AHighClosed-source component
CVE-2015-9186A-62261340N/AHighClosed-source component
CVE-2015-9150A-62261341N/AHighClosed-source component
CVE-2015-9147A-62261488N/AHighClosed-source component
CVE-2015-8593A-37535091N/AHighClosed-source component
CVE-2015-9160A-37546254N/AHighClosed-source component
CVE-2015-8594A-37546855N/AHighClosed-source component
CVE-2015-9145A-37535099N/AHighClosed-source component
CVE-2015-9143A-62260900N/AHighClosed-source component
CVE-2015-9157A-62260934N/AHighClosed-source component
CVE-2015-9141A-62261297N/AHighClosed-source component
CVE-2015-9140A-62259746N/AHighClosed-source component
CVE-2015-9135A-37546950N/AHighClosed-source component
CVE-2015-9138A-62259952N/AHighClosed-source component
CVE-2015-9136A-62260823N/AHighClosed-source component
CVE-2015-9137A-62260975N/AHighClosed-source component
CVE-2015-9131A-37542272N/AHighClosed-source component
CVE-2015-9139A-62251857N/AHighClosed-source component
CVE-2015-9130A-62252820N/AHighClosed-source component
CVE-2015-9129A-62260397N/AHighClosed-source component
CVE-2015-9133A-62260464N/AHighClosed-source component
CVE-2015-9127A-62260824N/AHighClosed-source component
CVE-2015-9132A-62260976N/AHighClosed-source component
CVE-2015-9134A-62261382N/AHighClosed-source component
CVE-2015-9128A-62261610N/AHighClosed-source component
CVE-2015-9065A-37538494N/AHighClosed-source component
CVE-2015-9064A-37546801N/AHighClosed-source component
CVE-2015-9063A-37546802N/AHighClosed-source component
CVE-2015-9126A-62258375N/AHighClosed-source component
CVE-2015-9124A-62252821N/AHighClosed-source component
CVE-2015-9142A-62260901N/AHighClosed-source component
CVE-2015-9066A-37540467N/AHighClosed-source component
CVE-2014-9998A-62260398N/AHighClosed-source component
CVE-2015-9220A-62261299N/AHighClosed-source component
CVE-2015-9122A-62261611N/AHighClosed-source component
CVE-2015-9123A-62259953N/AHighClosed-source component
CVE-2015-9118A-62261220N/AHighClosed-source component
CVE-2015-9120A-62261298N/AHighClosed-source component
CVE-2015-9119A-62261489N/AHighClosed-source component
CVE-2015-9116A-37540934N/AHighClosed-source component
CVE-2015-9115A-37544076N/AHighClosed-source component
CVE-2015-9113A-37544077N/AHighClosed-source component
CVE-2015-9112A-62258091N/AHighClosed-source component
CVE-2015-9114A-62259954N/AHighClosed-source component
CVE-2015-9111A-62260465N/AHighClosed-source component
CVE-2015-9108A-62260714N/AHighClosed-source component
CVE-2015-9109A-62260977N/AHighClosed-source component
CVE-2015-9110A-62261383N/AHighClosed-source component
CVE-2016-10492A-62261300N/AHighClosed-source component
CVE-2016-10482A-62260978N/AHighClosed-source component
CVE-2016-10483A-62258092N/AHighClosed-source component
CVE-2016-10489A-62258093N/AHighClosed-source component
CVE-2016-10487A-62259955N/AHighClosed-source component
CVE-2016-10477A-62260399N/AHighClosed-source component
CVE-2016-10485A-62260902N/AHighClosed-source component
CVE-2016-10478A-62260979N/AHighClosed-source component
CVE-2016-10476A-62260980N/AHighClosed-source component
CVE-2016-10475A-62260981N/AHighClosed-source component
CVE-2016-10474A-62260982N/AHighClosed-source component
CVE-2016-10494A-62261102N/AHighClosed-source component
CVE-2016-10484A-62261342N/AHighClosed-source component
CVE-2016-10491A-62261490N/AHighClosed-source component
CVE-2016-10486A-62267788N/AHighClosed-source component
CVE-2016-10472A-62259956N/AHighClosed-source component
CVE-2016-10490A-62260468N/AHighClosed-source component
CVE-2016-10480A-62261301N/AHighClosed-source component
CVE-2016-10467A-37526814N/AHighClosed-source component
CVE-2016-10495A-62261103N/AHighClosed-source component
CVE-2016-10481A-62260401N/AHighClosed-source component
CVE-2016-10479A-62261412N/AHighClosed-source component
CVE-2016-10384A-37536238N/AHighClosed-source component
CVE-2016-10385A-37544067N/AHighClosed-source component
CVE-2016-10452A-37523164N/AHighClosed-source component
CVE-2016-10423A-37534896N/AHighClosed-source component
CVE-2016-10424A-37540034N/AHighClosed-source component
CVE-2016-10449A-37546861N/AHighClosed-source component
CVE-2016-10454A-37544078N/AHighClosed-source component
CVE-2016-10450A-62260825N/AHighClosed-source component
CVE-2016-10451A-62267789N/AHighClosed-source component
CVE-2016-10386A-37534646N/AHighClosed-source component
CVE-2016-10469A-37542273N/AHighClosed-source component
CVE-2016-10440A-37535092N/AHighClosed-source component
CVE-2016-10499A-62259957N/AHighClosed-source component
CVE-2016-10446A-37547406N/AHighClosed-source component
CVE-2016-10473A-62260746N/AHighClosed-source component
CVE-2016-10466A-62260783N/AHighClosed-source component
CVE-2016-10457A-62260826N/AHighClosed-source component
CVE-2016-10442A-62267790N/AHighClosed-source component
CVE-2016-10433A-37540468N/AHighClosed-source component
CVE-2016-10430A-37540930N/AHighClosed-source component
CVE-2016-10445A-37545608N/AHighClosed-source component
CVE-2016-10426A-62252822N/AHighClosed-source component
CVE-2016-10435A-62260402N/AHighClosed-source component
CVE-2016-10425A-62260983N/AHighClosed-source component
CVE-2016-10438A-62261302N/AHighClosed-source component
CVE-2016-10436A-62261494N/AHighClosed-source component
CVE-2016-10439A-62263656N/AHighClosed-source component
CVE-2016-10431A-37540931N/AHighClosed-source component
CVE-2016-10434A-37540932N/AHighClosed-source component
CVE-2016-10432A-37546902N/AHighClosed-source component
CVE-2016-10462A-37539225N/AHighClosed-source component
CVE-2016-10443A-37540475N/AHighClosed-source component
CVE-2016-10427A-62261495N/AHighClosed-source component
CVE-2016-10387A-32583751N/AHighClosed-source component
CVE-2016-10390A-37536239N/AHighClosed-source component
CVE-2016-10498A-32582870N/AHighClosed-source component
CVE-2016-10419A-32577129N/AHighClosed-source component
CVE-2016-10420A-32579916N/AHighClosed-source component
CVE-2016-10429A-32579411N/AHighClosed-source component
CVE-2016-10493A-32574787N/AHighClosed-source component
CVE-2016-10447A-37542968N/AHighClosed-source component
CVE-2016-10444A-37544163N/AHighClosed-source component
CVE-2016-5348A-37546905N/AHighClosed-source component
CVE-2016-10421A-32579095N/AHighClosed-source component
CVE-2016-10455A-32580964N/AHighClosed-source component
CVE-2016-10441A-32582927N/AHighClosed-source component
CVE-2016-10418A-37547407N/AHighClosed-source component
CVE-2016-10417A-32576287N/AHighClosed-source component
CVE-2016-10464A-32580243N/AHighClosed-source component
CVE-2016-10458A-32583424N/AHighClosed-source component
CVE-2016-10471A-37539226N/AHighClosed-source component
CVE-2016-10416A-62259747N/AHighClosed-source component
CVE-2016-10411A-62260404N/AHighClosed-source component
CVE-2016-10496A-62260469N/AHighClosed-source component
CVE-2016-10410A-62260936N/AHighClosed-source component
CVE-2016-10414A-62260937N/AHighClosed-source component
CVE-2016-10461A-62263657N/AHighClosed-source component
CVE-2016-10460A-62271227N/AHighClosed-source component
CVE-2016-10392A-37544068N/AHighClosed-source component
CVE-2016-10409A-37544164N/AHighClosed-source component
CVE-2016-10459A-62260716N/AHighClosed-source component
CVE-2016-10407A-62261222N/AHighClosed-source component
CVE-2016-10406A-62267791N/AHighClosed-source component
CVE-2016-10497A-62271228N/AHighClosed-source component
CVE-2016-10501A-62261303N/AHighClosed-source component
CVE-2016-10381A-37539788N/AModerateClosed-source component
CVE-2016-10380A-37541976N/AModerateClosed-source component
CVE-2016-10412A-37536245N/AModerateClosed-source component
CVE-2016-10415A-62260403N/AModerateClosed-source component
CVE-2016-10422A-37542966N/AModerateClosed-source component
CVE-2016-10456A-62261413N/AModerateClosed-source component
CVE-2016-10428A-37534697N/AModerateClosed-source component
CVE-2016-10448A-62261414N/AModerateClosed-source component
CVE-2016-10437A-62260715N/AModerateClosed-source component

 

Full details of the April 2018 Android Security Bulletin are available here.

 

My Cart Close (×)

Your cart is empty
Browse Shop

Rapid Mobile

Rapid Mobile uses cookies, tokens, and other third party scripts to recognise visitors of our sites and services, remember your settings and privacy choices, and - depending on your settings and privacy choices - enable us and some key partners to collect information about you so that we can improve our services and deliver relevant ads.

 

By continuing to use our site or clicking I Accept, you agree that Rapid Mobile and our key partners may collect data and use cookies for personalised ads and other purposes, as described more fully in our privacy policy.

 

You can change your settings at any time by clicking Manage Settings or by visiting our Privacy Centre for more detailed information.

 

Privacy Settings saved!
Cookie Services

We need your consent so that we and our trusted partners can store and access cookies, unique identifiers, personal data and information about your browsing behaviour on your device. This enables us to serve relevant content and advertising to you, and to improve the service that we provide to our readers. This only applies to rapidmobile.biz.Because we respect your right to privacy, you can choose not to allow some types of cookies. Click on the different category headings to find out more and change our default settings. However, blocking some types of cookies may impact your experience of the site and the services we are able to offer.

These cookies allow us to count visits and traffic sources, so we can measure and improve the performance of our site.

We track anonymized user information to improve our website.
  • _ga
  • _gid
  • _gat

Save my preferences