Google releases July 2016 Android Security Bulletin and Nexus Images

Last updated:

Google has released the July 2016 Android Security Bulletin. Partners have had access to the warnings in this month’s bulletin since June 6, 2016 or earlier.

The most severe of these issues is a Critical security vulnerability that could enable remote code execution on an affected device through multiple methods such as email, web browsing, and MMS when processing media files.

Interestingly, this bulletin defines two security patch level strings to provide Android partners with the flexibility to move more quickly to fix a subset of vulnerabilities that are similar across all Android devices.

  • 2016-07-01: Partial security patch level string. This security patch level string indicates that all issues associated 2016-07-01 are addressed.
  • 2016-07-05: Complete security patch level string. This security patch level string indicates that all issues associated 2016-07-01 and 2016-07-05 are addressed.

Alongside the bulletin, Google have released a security update to Nexus devices through an over-the-air (OTA) update. The Nexus firmware images have also been released to the Google Developer site. Source code patches for these issues will be released to the Android Open Source Project (AOSP) repository in the next 48 hours.

The table below contains a list of security vulnerabilities, the Common Vulnerability and Exposures ID (CVE), their assessed severity and whether or not Nexus devices are affected.

The severity assessment is based on the effect that exploiting the vulnerability would possibly have on an affected device, assuming the platform and service mitigations are disabled for development purposes or successfully bypassed.

Security patch levels of 2016-07-01 or later must address the following issues.
[table style=”table-striped”]

IssueCVESeverityAffects Nexus?
Remote code execution vulnerability in MediaserverCVE-2016-2506, CVE-2016-2505, CVE-2016-2507, CVE-2016-2508, CVE-2016-3741, CVE-2016-3742, CVE-2016-3743CriticalYes
Remote code execution vulnerability in OpenSSL & BoringSSLCVE-2016-2108CriticalYes
Remote code execution vulnerability in BluetoothCVE-2016-3744HighYes
Elevation of privilege vulnerability in libpngCVE-2016-3751HighYes
Elevation of privilege vulnerability in MediaserverCVE-2016-3745, CVE-2016-3746, CVE-2016-3747HighYes
Elevation of privilege vulnerability in socketsCVE-2016-3748HighYes
Elevation of privilege vulnerability in LockSettingsServiceCVE-2016-3749HighYes
Elevation of privilege vulnerability in Framework APIsCVE-2016-3750HighYes
Elevation of privilege vulnerability in ChooserTarget serviceCVE-2016-3752HighYes
Information disclosure vulnerability in MediaserverCVE-2016-3753HighNo*
Information disclosure vulnerability in OpenSSLCVE-2016-2107HighNo*
Denial of service vulnerability in MediaserverCVE-2016-3754, CVE-2016-3755, CVE-2016-3756HighYes
Denial of service vulnerability in libcCVE-2016-3818HighNo*
Elevation of privilege vulnerability in lsofCVE-2016-3757ModerateYes
Elevation of privilege vulnerability in DexClassLoaderCVE-2016-3758ModerateYes
Elevation of privilege vulnerability in Framework APIsCVE-2016-3759ModerateYes
Elevation of privilege vulnerability in BluetoothCVE-2016-3760ModerateYes
Elevation of privilege vulnerability in NFCCVE-2016-3761ModerateYes
Elevation of privilege vulnerability in socketsCVE-2016-3762ModerateYes
Information disclosure vulnerability in Proxy Auto-ConfigCVE-2016-3763ModerateYes
Information disclosure vulnerability in MediaserverCVE-2016-3764, CVE-2016-3765ModerateYes
Denial of service vulnerability in MediaserverCVE-2016-3766ModerateYes

[/table]

Security patch levels of 2016-07-05 or later must address all of the 2016-07-01 issues as well as the following issues.
[table style=”table-striped”]

IssueCVESeverityAffects Nexus?
Elevation of privilege vulnerability in Qualcomm GPU driver (Device specific)CVE-2016-2503, CVE-2016-2067CriticalYes
Elevation of privilege vulnerability in MediaTek Wi-Fi driver (Device specific)CVE-2016-3767CriticalYes
Elevation of privilege vulnerability in Qualcomm performance component (Device specific)CVE-2016-3768CriticalYes
Elevation of privilege vulnerability in NVIDIA video driver (Device specific)CVE-2016-3769CriticalYes
Elevation of privilege vulnerability in MediaTek drivers (Device specific)CVE-2016-3770, CVE-2016-3771, CVE-2016-3772, CVE-2016-3773, CVE-2016-3774CriticalYes
Elevation of privilege vulnerability in kernel file system (Device specific)CVE-2016-3775CriticalYes
Elevation of privilege vulnerability in USB driver (Device specific)CVE-2015-8816CriticalYes
Elevation of privilege vulnerability in Qualcomm components (Device specific)CVE-2014-9794, CVE-2014-9795, CVE-2015-8892, CVE-2013-7457, CVE-2014-9781, CVE-2014-9786, CVE-2014-9788, CVE-2014-9779, CVE-2014-9780, CVE-2014-9789, CVE-2014-9793, CVE-2014-9782, CVE-2014-9783, CVE-2014-9785, CVE-2014-9787, CVE-2014-9784, CVE-2014-9777, CVE-2014-9778, CVE-2014-9790, CVE-2014-9792, CVE-2014-9797, CVE-2014-9791, CVE-2014-9796, CVE-2014-9800, CVE-2014-9799, CVE-2014-9801, CVE-2014-9802, CVE-2015-8891, CVE-2015-8888, CVE-2015-8889, CVE-2015-8890HighYes
Elevation of privilege vulnerability in Qualcomm USB driver (Device specific)CVE-2016-2502HighYes
Elevation of privilege vulnerability in Qualcomm Wi-Fi driver (Device specific)CVE-2016-3792HighYes
Elevation of privilege vulnerability in Qualcomm camera driver (Device specific)CVE-2016-2501HighYes
Elevation of privilege vulnerability in NVIDIA camera driver (Device specific)CVE-2016-3793, CVE-2016-3794HighYes
Elevation of privilege vulnerability in MediaTek power driver (Device specific)CVE-2016-3795, CVE-2016-3796HighYes
Elevation of privilege vulnerability in Qualcomm Wi-Fi driver (Device specific)CVE-2016-3797HighYes
Elevation of privilege vulnerability in MediaTek hardware sensor driver (Device specific)CVE-2016-3798HighYes
Elevation of privilege vulnerability in MediaTek video driver (Device specific)CVE-2016-3799, CVE-2016-3800HighYes
Elevation of privilege vulnerability in MediaTek GPS driver (Device specific)CVE-2016-3801HighYes
Elevation of privilege vulnerability in kernel file system (Device specific)CVE-2016-3802, CVE-2016-3803HighYes
Elevation of privilege vulnerability in MediaTek power management driver (Device specific)CVE-2016-3804, CVE-2016-3805HighYes
Elevation of privilege vulnerability in MediaTek display driver (Device specific)CVE-2016-3806HighYes
Elevation of privilege vulnerability in serial peripheral interface driver (Device specific)CVE-2016-3807, CVE-2016-3808HighYes
Elevation of privilege vulnerability in Qualcomm sound driver (Device specific)CVE-2016-2068HighYes
Elevation of privilege vulnerability in kernel (Device specific)CVE-2014-9803HighYes
Information disclosure vulnerability in networking component (Device specific)CVE-2016-3809HighYes
Information disclosure vulnerability in MediaTek Wi-Fi driver (Device specific)CVE-2016-3810HighYes
Elevation of privilege vulnerability in kernel video driver (Device specific)CVE-2016-3811ModerateYes
Information disclosure vulnerability in MediaTek video codec driver (Device specific)CVE-2016-3812ModerateYes
Information disclosure vulnerability in Qualcomm USB driver (Device specific)CVE-2016-3813ModerateYes
Information disclosure vulnerability in NVIDIA camera driver (Device specific)CVE-2016-3814, CVE-2016-3815ModerateYes
Information disclosure vulnerability in MediaTek display driver (Device specific)CVE-2016-3816ModerateYes
Information disclosure vulnerability in kernel teletype driver (Device specific)CVE-2016-0723ModerateYes
Denial of service vulnerability in Qualcomm bootloader (Device specific)CVE-2014-9798, CVE-2015-8893ModerateYes

[/table]

Android and Google Service Mitigations

This is a summary of the mitigations provided by the Android security platform and service protections such as SafetyNet. These capabilities reduce the likelihood that security vulnerabilities could be successfully exploited on Android.

  • Exploitation for many issues on Android is made more difficult by enhancements in newer versions of the Android platform. We encourage all users to update to the latest version of Android where possible.
  • The Android Security team actively monitors for abuse with Verify Apps and SafetyNet, which are designed to warn users about Potentially Harmful Applications. Verify Apps is enabled by default on devices with Google Mobile Services, and is especially important for users who install applications from outside of Google Play. Device rooting tools are prohibited within Google Play, but Verify Apps warns users when they attempt to install a detected rooting application—no matter where it comes from. Additionally, Verify Apps attempts to identify and block installation of known malicious applications that exploit a privilege escalation vulnerability. If such an application has already been installed, Verify Apps will notify the user and attempt to remove the detected application.
  • As appropriate, Google Hangouts and Messenger applications do not automatically pass media to processes such as Mediaserver.

Full details of the July 2016 Android Security Bulletin is available here.

Rapid Mobile

Rapid Mobile uses cookies, tokens, and other third party scripts to recognise visitors of our sites and services, remember your settings and privacy choices, and - depending on your settings and privacy choices - enable us and some key partners to collect information about you so that we can improve our services and deliver relevant ads.

 

By continuing to use our site or clicking I Accept, you agree that Rapid Mobile and our key partners may collect data and use cookies for personalised ads and other purposes, as described more fully in our privacy policy.

 

You can change your settings at any time by clicking Manage Settings or by visiting our Privacy Centre for more detailed information.

 

Privacy Settings saved!
Cookie Services

When you visit any website, it may store or retrieve information on your browser, mostly in the form of cookies.Because we respect your right to privacy, you can choose not to allow some types of cookies. Click on the different category headings to find out more and change our default settings. However, blocking some types of cookies may impact your experience of the site and the services we are able to offer.

These cookies allow us to count visits and traffic sources, so we can measure and improve the performance of our site.

We track anonymized user information to improve our website.
  • _ga
  • _gid
  • _gat

Decline all Services
Accept all Services